PostSharp 5.0 breaks Azure Publish profile

gustinn's Avatar

gustinn

28 Sep, 2017 07:20 AM

I have already tried this several times, with uninstalling and re-installing Visual Studio 2017 and PostSharp 5.0.34.
The result is always the same: until I install PostSharp, everything works fine.

After installing PostSharp, I cannot deploy my Azure App Service from Visual Studio 2017 any more.
Trying to Publish results in the following error message:

[...]\VisualStudio\v15.0\Web\Microsoft.Web.Publishing.targets(4077,5): Error : Web Deploy publish/package validating error: Missing or Invalid property value for $(MsDeployServiceUrl)
[...]\VisualStudio\v15.0\Web\Microsoft.Web.Publishing.targets(4084,5): Error : Target GenerateGlobalPublishSetting Failed

I.e. PostSharp 5.0.34 breaks VS 2017 Web Publishing somehow...
Plz help.

Thx a lot in advance!

  1. Support Staff 1 Posted by PostSharp Techn... on 30 Sep, 2017 09:49 PM

    PostSharp Technologies's Avatar

    Hello,

    we were not able to reproduce the issue with basic Azure projects publishing on Azure. Could you please send us a reproduction or instruct us how to reproduce the problem?

    Thanks!

    All the best,
    Daniel

  2. 2 Posted by gustinn on 04 Oct, 2017 08:34 PM

    gustinn's Avatar

    Hello,

    I've created a sample Web API for this: github.com/GustinAG/hello-web-api.

    Steps to Reproduce

    1. Uninstall Visual Studio and PostSharp - if present.
    2. Install Visual Studio 2017 Update 3.5.
    3. Open and build my sample solution.
    4. Adjust the publish profile to your arbitrary Azure App Service.
    5. Publish the Hello Web API - that should work.
    6. Install PostSharp 5.0.34.
    7. Try to publish Hello Web API again. Now, you get the error messages above.
  3. Support Staff 3 Posted by PostSharp Techn... on 06 Oct, 2017 04:07 PM

    PostSharp Technologies's Avatar

    Hello,

    thank you for the steps to reproduce. Yet, I'm not able to get the same results.

    Step 6: I tried to install both PostSharp 5.0.34 nuget package and PostSharp 5.0.34 Tools for Visual Studio both separately and at the same time.

    I would like to run more tests for this issue, but in the mean time, please, could you try to update to PostSharp 5.0.35 (both nuget package and Tools for Visual Studio)? PostSharp 5.0.35 contains a fix for a bug that interfere with Visual Studio build processes in an annoying way. I have a little hope that this version could fix Azure publishing issue as well.

    Best regards,
    -jakub

  4. 4 Posted by gustinn on 06 Oct, 2017 05:38 PM

    gustinn's Avatar

    Hello,

    thank you very much: I've just installed PostSharp 5.0.35 Tools and that resolved my issue.   ✔

  5. Support Staff 5 Posted by PostSharp Techn... on 09 Oct, 2017 09:18 AM

    PostSharp Technologies's Avatar

    Hello,

    I'm happy to hear that your issue has been solved. Thank you for your feedback!

    We are going to close this request. Please feel free to reopen the discussion if you need more help.

    Best regards,
    -tony

  6. PostSharp Technologies closed this discussion on 09 Oct, 2017 09:18 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac