Invalid License Notification After Registering New License

ben.brandt's Avatar

ben.brandt

30 Nov, 2017 04:43 PM

Some of our developers received/registered an update to their PostSharp license for v5 that expires end of 2018.

Upon building, a notification is displayed that we are using a version of PostSharp that our current license does not cover.

Investigating further, we noticed that multiple expired licenses appear in the PostSharp license dialog along with the current PostSharp license.

When we try to remove the old license to avoid getting the notification, the remove license process has no effect.

Primarily, we do not want our developers with a valid license receiving notifications that their license is expired. How do we fix this?

  1. Support Staff 1 Posted by PostSharp Techn... on 30 Nov, 2017 05:19 PM

    PostSharp Technologies's Avatar

    Hello again,

    to let us investigate the issue with the license removal process, may I ask you to tell us which PostSharp Tools for Visual Studio you have installed?

    We'd also need an export of PostSharp registry hive, which can be found in HKEY_CURRENT_USER\Software\SharpCrafters\PostSharp 3 and HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\SharpCrafters\PostSharp 3.

    To avoid the notifications, you can remove LicenseKey value and LicenseKeys key from the locations mentioned above and register the valid key(s) again.

    Best regards,
    -tony

  2. Support Staff 2 Posted by PostSharp Techn... on 13 Dec, 2017 02:51 PM

    PostSharp Technologies's Avatar

    Hello,

    We are going to close this request as there have not been any further updates. Please feel free to reopen the discussion if you need more help.

    Thanks,
    PostSharp Team

  3. PostSharp Technologies closed this discussion on 13 Dec, 2017 02:51 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac