Compiler service crash

nikolai.doroshenko's Avatar

nikolai.doroshenko

23 Apr, 2018 10:52 AM

Dear Ladies and Gentlemen,

for at least 1 1/2 weeks i'm entcountering a P# bug. When I try to build my solution it happens quiet frequently that the compiler service crashes. This crash occurs approximately 2-3 times in an hour.
In addition a P# warning pops up in the output window: "The pipe server hasn't started due time."
I already tried to reinstall P#. And i can't remeber any major changes, which could affect my Visual Studio settings.

P# version: 5.0.49
VS version: VS Enterprise 2017 Version 15.5.7
.NET Framework Version: 4.7.02558

Thanks for helping!

  1. Support Staff 1 Posted by PostSharp Techn... on 23 Apr, 2018 05:04 PM

    PostSharp Technologies's Avatar

    Hello,

    We had other teams at Siemens reporting a similar issue that was caused by Trend Micro antivirus. If you're using antivirus software on your machine, then please try to disable active process monitoring in its settings.

    If changing antivirus settings doesn't help, then please try to set PostSharpHost MSBuild property to Native and rebuild the solution. You can set the host in the project properties (http://doc.postsharp.net/configuration-vs-project) or in the csproj file (http://doc.postsharp.net/configuration-msbuild). This should produce a different error message, which hopefully will point us to the root cause.

    -alex

  2. 2 Posted by nikolai.doroshe... on 24 Apr, 2018 06:43 AM

    nikolai.doroshenko's Avatar

    Hi alex,

    the first solution with the antivirus software won't work, because I have no permission to change my local machine settings.

    I tried your second suggestion too, and the solution crashed after the first build.
    Following error message was shown to me:
    The process C:\...\PostSharp\5.0.37\bin.Release\postsharp-net40-x86-native.exe exited with code -1073741819.

    It is kinda suspicious that folder structure is hinting to the version 5.0.37.

    What i have forgotten to say yesterday:
    Complied images are also installed for the following versions of postsharp:

    5.0.34.0
    5.0.37.0

    EDIT: Uninstalling both compiled image versions didn't help either.

    Greetings
    Nikolai

  3. 3 Posted by nikolai.doroshe... on 25 Apr, 2018 10:57 AM

    nikolai.doroshenko's Avatar

    I got a solution for my problem:
    I completely reinstalled Visual Studio and now it seems that it works stable again.

    If i dont post any other comments see this solution as the final one!

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac