Unable to detect compatible .net core runtime v 6.0.21

Esben Bach's Avatar

Esben Bach

30 Jul, 2018 06:08 AM

I upgraded to 6.0.21 for one of my solutions, and I now get an error explaining that my version of dotnet.exe does not support --list-runtimes and error about not finding a compatible version.


The version of dotnet.exe installed on your computer does not support the --list-runtimes flag. Please install a more recent version.
Unable to detect compatible .NET Core runtime version to execute PostSharp. Please report this error via https://www.postsharp.net/support. .NET Core runtime version for executing PostSharp can be set explicitly using PostSharpToolsRuntimeVersion MSBuild property. The version has to be compatible with the target framework of your project.

Not surprisingly I don't have the correct .NET core runtime version installed. You might consider expanding the error message with a "minimum version of .NET Core SDK" or some such, for instance dotnet.exe v 2.1.202 is built using the .NET Core 2.0 Runtime and does not have that option - im not sure when it got there, but at least v 2.1.300 has it.

  1. Support Staff 1 Posted by PostSharp Techn... on 30 Jul, 2018 09:05 AM

    PostSharp Technologies's Avatar

    Esben, thank you for the feedback. The error message will be fixed in the next build.


  2. Support Staff 2 Posted by PostSharp Techn... on 14 Aug, 2018 03:48 PM

    PostSharp Technologies's Avatar


    The confusing error message regarding the .NET Core SDK version has been fixed in PostSharp build 6.0.23.


  3. PostSharp Technologies closed this discussion on 14 Aug, 2018 03:48 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac