.net 4.7.1 Error

mayank's Avatar

mayank

13 Sep, 2018 06:24 PM

I am getting attached error in VS.

Postsharp.Settings.Exe - This application could not be started.
This application requires one of the following versions of the .Net Framework

.net Framework, Version =v4.7.1

  1. Support Staff 1 Posted by PostSharp Techn... on 14 Sep, 2018 10:35 AM

    PostSharp Technologies's Avatar

    Hello,

    PostSharp 6.0 requires .NET Framework 4.7.1 or newer to be installed on development or build machine. See http://doc.postsharp.net/requirements.

    If you are using older version of PostSharp for building and this is happening in Visual Studio, you can install the respective version of PostSharp Tools for Visual Studio available at https://www.postsharp.net/downloads.

    (The information about releases is outdated there an is going to be updated today. The latest stable release is 6.0, development release is 6.1 and 5.0 is no longer supported. The only other supported version is 4.3. See https://www.postsharp.net/support/policies for details.)

    Best regards,
    -tony

  2. 2 Posted by mayank on 14 Sep, 2018 01:14 PM

    mayank's Avatar

    Yes, 4.7.2 is installed on the machine. I am using 6.0 release.

  3. Support Staff 3 Posted by PostSharp Techn... on 14 Sep, 2018 04:01 PM

    PostSharp Technologies's Avatar

    Thank you for the update.

    I'm afraid I don't have a better suggestion than to try to reinstall .NET Framework from https://www.microsoft.com/net/download/dotnet-framework-runtime and to check in registry that the version 4.7.2 is really installed - see https://docs.microsoft.com/en-us/dotnet/framework/migration-guide/h....

    Is this a problem isolated just to one machine or do you have the same issue on other machines? Which version of Windows do you use?

    Best regards,
    -tony

  4. 4 Posted by mayank on 14 Sep, 2018 04:03 PM

    mayank's Avatar

    Yes, it is really installed. I have other programs that use it as well. In your config file you are marking 4.7.1 as required, if I go and change it to 4.7.2 then it starts to work just fine.

  5. Support Staff 5 Posted by PostSharp Techn... on 21 Sep, 2018 10:49 AM

    PostSharp Technologies's Avatar

    Hello,

    We are going to close this request as there have not been any further updates. Please feel free to reopen the discussion if you need more help.

    Thanks,
    -alex

  6. PostSharp Technologies closed this discussion on 21 Sep, 2018 10:49 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac