Experimental .NET Standard 2.0 support - which versions?

avatar's Avatar

avatar

22 Sep, 2017 01:40 PM

With regard to this, I saw here - http://support.sharpcrafters.com/discussions/questions/2618-postsha... - the statement that "Experimental support for .NET Standard 2.0 and .NET Core 2.0 has been released. We'll continue the efforts during the next weeks.".

Is there a specific version/build I should be using to experiment with this? Using 5.0.34, compiling a .NET Standard 2.0 project still fails with a PS0099 error as soon as the PostSharp NuGet package is added to it, even if the project is empty (i.e. contains no code files at all).

Regards,

Alistair

  1. Support Staff 1 Posted by PostSharp Techn... on 23 Sep, 2017 09:03 AM

    PostSharp Technologies's Avatar

    Hello,

    there was a combination of fixes included that broke .Net Standard 2.0 build in the hotfix release. We have all fixed in our codebase and will be releasing another hotfix soon.

    I apologize for the inconvenience. We hope that we will have stable version (including test coverage) soon.

    (issue #15524)

    Best regards,
    Daniel

  2. Support Staff 2 Posted by PostSharp Techn... on 06 Oct, 2017 07:20 AM

    PostSharp Technologies's Avatar

    Hello,

    We've released a fix to this issue in PostSharp 5.0.35. Please update your NuGet packages.
    Thank you,

    -gael

  3. PostSharp Technologies closed this discussion on 06 Oct, 2017 07:20 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac